Inicio > codear, linux, ubuntu-ar > Samsung Syncmaster 206/226 NW en Ubuntu

Samsung Syncmaster 206/226 NW en Ubuntu

Sábado, 14 de julio de 2007 Dejar un comentario Ir a comentarios

Tengo chiche nuevo!

Después de algún tiempo de sacrificado laburo, me dí uno de los mayores gustos “informáticos” hasta ahora: comprarme un monitor LCD de 22″ wide… más precisamente el Samsung Syncmaster 226 NW. 😀

De más está decir que es fantabuloso cómo se ve cualquier cosa que uno quiera ver. No hay “efecto arrastre” al hacer scroll, excelente contraste, excelente resolución y nitidez… Lo único “malo” técnicamente es que no viene con conexión DVI.

Sobre esto último, leí por ahí que en Argentina el IVA es del 21% para los monitores con DVI, en cambio para los con conexión VGA analógica es el 10,5%; de hecho, acá en Argentina los 206/226 BW (son iguales pero con DVI) no se venden (un garrón).

Llegué a casa, saqué el viejo y querido Samsung 796MB y me dispuse a disfrutar mi Ubuntu Feisty con él. Claro, Ubuntu estaba configurado con la “vieja” resolución (1024×768). Tenía que cambiar a la “nueva” resolución: 1680×1050 (los monitores LCD siempre deben estar a resolución nativa); para eso, abri una consola y ejecuté “dpkg-reconfigure xserver-xorg”. Joya, seleccioné las resoluciones que quería (1680×1050 entre ellas), me generó un xorg.conf nuevo (con las resoluciones/configuraciones seleccionadas, haciendo un backup del xorg.conf anterior) y reinicié la PC.

Pero me encontré con un (bug?) problema: Gdm no arrancaba! 🙁

El síntoma era: X arrancaba, parece que arrancaba de nuevo, veía el fondo “cuadriculado” en blanco y negro típico de X y el cursor de Gnome en “espera”. Listo, no pasaba más de ahí. Era cuestión de hacer Ctrl+Alt+F1 y loguearse en la consola de texto. Hice un “top” y me mostraba el Gdm funcionando, pero comiéndose la CPU al 100%! No quedaba otra más que matarlo. Arrancando con el Live-CD de Ubuntu, el proceso de arranque detectaba los 1680×1050 y pude usar Gnome desde el CD como si nada.

Si volvía al xorg.conf anterior, funcionaba, pero no tenía resolución nativa. Utilizando nvidia-settings claro que podía configurar el monitor a la resolución que quería, pero setearlo a mano cada vez que iniciaba sesión no me parecía una opción. Tenía que googlear, y encontré este link. Sencillito. Fui hasta la parte de “drivers nvidia” (tengo una Nvidia 6600) y ejecuté el nvidia-settings como root, generé con el programa un xorg.conf nuevo desde ahí y restartié gdm. Ahora sí arrancaba bien, y a 1680×1050.

Pero me faltaban los efectos de Beryl (Compiz Fusion está en desarrollo todavía). Claro, el nvidia-settings sí incluye la opción de GLX, pero no incluye el Composite (creo que es necesario todavía)… bah, en realidad me generó un xorg.conf bastante limpito, y tuve que copiar/pegar algunas opciones de configuración que en su momento agregué para Beryl.

Este es el xorg.conf que me quedó, para el que lo quiera bajar.

Conclusión:
Bueh, fue un rato dando vueltas; a Ubuntu (y las distros GNU/Linux en general) les queda un poco de laburo el tema de la configuración de las resoluciones de los monitores (estamos en el 2007 y uno tiene que configurar el xorg.conf a mano…). Esperemos que en Ubuntu 7.10 Gutsy Gibbon, con este proyecto que va a estar incluído, más X.org 7.3, este problema se solucione.

(ahora, a disfrutar!)

Saludos!
Marcelo

Categories: codear, linux, ubuntu-ar Tags:
  1. Federico
    Jueves, 9 de agosto de 2007 a las 20:45 | #1

    Que tal Marcelo? Desde ya que te felicito por el monitor.

    Yo compre el mismo modelo pero de 20 pulgadas. Lo acabo de instalar en un Windows XP y noto que en los colores oscuros se ven lineas de fondo tipo trueno si presto mucha atencion.¿A vos te pasa lo mismo? Desde ya te agradezco la rsta!

  2. Marcelo
    Viernes, 10 de agosto de 2007 a las 13:43 | #2

    Uhm… no, no me pasa, el negro se ve perfecto. Igualmente atacaría el cable (largo, con extensiones y/o de mala calidad) o alguna interferencia que puedas estar teniendo. Esto que te pasa es una de las cosas “malas” de que este monitor tenga interfaz analógica. 🙁

    Saludos
    Marcelo

  3. Marceloz
    Domingo, 23 de septiembre de 2007 a las 23:35 | #3

    Federico, lei por ahi que hay diferentes partidas de pantallas LCD, y algunas vinieron con algun tipo de falla (creo que el numero de modelo terminado con A, ya que el que termina con S no tendra problemas…)

    Fijate por los foros
    suerte!

  4. Guille
    Jueves, 27 de diciembre de 2007 a las 16:46 | #4

    Hola Marcelo, me compre el 226nw, tengo una 6600LE y también uso ubuntu.
    El problema que tengo es que se ve muy brillante y queiro bajarle el brillo. Entonces, entro a nvidia-setting como root y le bajo el brillo a -0.62. Pero cuando aparece el screensaver, se me vuelve a subir el brillo :(.
    Me puse a ver tu xorg y note que usas una frecuencia de 59Hz.
    este es mi xorg http://rapidshare.com/files/79463657/xorg.conf.html
    Help!!
    Gracias

  5. cacus
    Sábado, 16 de febrero de 2008 a las 23:16 | #5

    Marcelo muchas gracias por tus comentarios y tips… Acabo de comprarme uno de estos chiches… Pero tengo otro problema distinto al tuyo: logro setear la resolución desde el sudo nvidia-settings pero me aparece la mitad de la pantalla en negro :(.
    Toqueteando el xorg.conf y dejándolo muy parecido al tuyo logro tener toda la pantalla completa pero sólo en gnome a prueba de fallos :S.
    A ver si se entiende mejor: cuando inicia ubuntu entra a GDM (se ve perfecta la pantalla de login, en la resolución que quiero y la pantalla completa), ni bien doy a “enter” después de que pongo mi pass pareciera que todo va bien pero de golpe (aún sin aparecer el fondo de pantalla ni nada del resto de las cosas) se cierra y me vuelve a la pantalla de login… No sé qué puede ser pero me tiene un tanto loco, creo que es un bug de GDM o gnome, pero no tengo más que ese dato… Alguna idea?

  6. Marcelo
    Domingo, 17 de febrero de 2008 a las 12:27 | #6

    Hola Juan Cruz! (alias “cacus”) 🙂

    Por casualidad, ¿tenés activado “Compiz”? (Es decir, los “efectos visuales” que están en Sistema -> Preferencias -> Apariencia -> Efectos Visuales)…

    Si es así, el problema puede venir por ahí, aunque de todas maneras dudo mucho que sea un problema del monitor.

    Te sugiero que te suscribas a una lista de correo de usuarios Ubuntu (o Linux), como Ubuntu Argentina, así te sacás dudas y entre los muchos que somos te damos una mano:

    http://ubuntu-ar.org/

    Saludos
    Marcelo

  1. Sin trackbacks aún.