Inicio > codear, linux, ubuntu-ar > Sufrís “versionitis”?

Sufrís “versionitis”?

Domingo, 1 de julio de 2007 Dejar un comentario Ir a comentarios

Una de las cosas que hacen estable y previsible a una distribución como Ubuntu es que una vez que fue lanzada una versión definitiva, las actualizaciones de los programas que contiene sólo se limitan a correcciones de seguridad o errores críticos. Esto está bueno, si uno quiere que todo “sólo funcione” una vez se configuró y la PC se comenzó a usar diariamente; lo mismo pasa si se usa la PC para laburar y necesita que todo ande de forma ordenada y sin sobresaltos.

Sin embargo, muchas veces uno navega por la web y lee cómo los distintos programas se van actualizando y van incluyendo funcionalidades interesantes, necesarias y hasta divertidas. Y ahí está uno para decir “yo quiero eso!”… y tiene que conformarse a esperar 6 meses por “eso”. 😀

Por suerte encontré www.getdeb.net, un sitio creado por gente interesada en brindar últimas versiones de paquetes para Ubuntu (para 32 y 64 bits), muy ameno y en castellano. No estaría posteando esto si no hubiera probado ningún paquete, pero me instalé el Pidgin (ex Gaim), el último DeVeDe (programa para hacer DVDs muy sencillo), y sólo fue bajar, doble click y listo. GDebi, el programa gráfico para instalar paquetes .deb “solitarios” se encarga de todo.

El sitio está muy bien organizado (por categorías), y ni tiene paquetes “a lo loco” ni está vacío. Considero que con la cantidad que hay, está “bien”, ya que un usuario nuevo no se marea (como puede pasar con el Synaptic). También tiene un feed RSS, para que lo agregue a mi Google Reader y ver todos los días qué novedades hay. Cada paquete tiene una página “propia”, donde se puede ver una captura de pantalla del programa, y algún comentario de algún usuario, donde se pueden hacer preguntas o comentar inconvenientes que se tuvo al usar/instalar (no se olviden, algunas versiones son de desarrollo, o en etapa de “pruebas”).

Por último, también permite “filtrar” para qué versión de Ubuntu estoy buscando paquetes (Dapper, Edgy y Feisty en sus versiones de 32 y 64 bits). Todo bastante completito, bien presentado y explicado, con el “look and feel” de las páginas web de Ubuntu.

Lo bueno es que esto acerca mucha más gente que no sabe compilar* a probar las versiones de desarrollo de los programas, involucrarse con la comunidad, y proveer feedback a los desarrolladores de software libre.

Como una de las formas de colaborar según la página de colaboración es haciéndose eco de este esfuerzo… acá está, muchachos. 😀

Gracias por el gran esfuerzo que hacen y ojalá sigan así.

* dije compilar porque es, en mi opinión, el principal obstáculo de los usuarios nuevos al querer testear o utilizar software en desarrollo.

Saludos!
Marcelo

Actualización: Instalé también el deb del nspluginwrapper para poder (por fin!) usar el Firefox de 64 bits en vez del de 32 bits (que usaba porque Adobe no lanzó todavía una versión de 64 bits del plugin de Flash)… y funciona 10 puntos, justo como dice la página:

1 -Descargar el .tar.gz desde el sitio de Adobe.
2 – Extraer el archivo libflashplayer.so a /usr/lib/mozilla/plugins/
3 – Abrir la terminal y ejecutar (como usuario, sin ‘sudo’):

nspluginwrapper -i /usr/lib/mozilla/plugins/libflashplayer.so

Aclaración: El paso 3 debe seguirse para cada usuario del sistema.

Categories: codear, linux, ubuntu-ar Tags:
  1. Edu
    Sábado, 14 de julio de 2007 a las 14:57 | #1

    Muy buen sitio, che!
    Ya lo agregué a mi del.cio.us

  2. Tomas
    Sábado, 13 de octubre de 2007 a las 02:01 | #2

    Muy buena data Marce, tenes idea que tipo de problemas tiene el instalar paquetes en desarrollo teniendo instalado las versiones estables del mismo paquete?

    Ejemplo, tengo UNBUNTU feisty, e instalo el devede; uso getdeb, e instalo devede pero version en desarrollo.

    El mismo software me configura la actual version o tendre que desinstalar a mano la version anterior? mientras espero la respuesta, pruebo la novedad 🙂

    Saludos.

    Tomas Delvechio.

  1. Sin trackbacks aún.