Inicio > codear, linux, tests, ubuntu-ar > Adobe Reader 8.1 para Linux

Adobe Reader 8.1 para Linux

Jueves, 8 de noviembre de 2007 Dejar un comentario Ir a comentarios

Si, si, ya sé que para leer simplemente un archivo pdf Evince y/o Kpdf funcionan bien… pero… y si me llega algún pdf “raro”, que aprovecha las características nuevas del formato? (uso de formularios, anotaciones, encriptación, etc.)[1]

En fin… me enteré hace poquito que Adobe (muy silenciosamente) lanzó su versión 8.1 del “acroread”, es decir, del Adobe Reader para Solaris/Sparc y GNU/Linux/i386. Con este programa tenemos máxima compatibilidad al leer y trabajar con estos archivos.

Lo bueno:

  • Anda rapidísimo, vuela comparado con la antigüa versión 7 (siempre sobre Linux); sigue utilizando GTK como toolkit gráfico.
  • Eliminaron el modo MDI, que nunca fue soportado por GTK (o sea, lo habían metido “a la fuerza”), con lo cual la versión 7 era un hack horrible al laburar con varios documentos. Ahora está todo en SDI. 🙂
  • Hay más comunicación con el equipo de desarrollo y el usuario: Adobe creó un blog sobre Acroread para Unix/Linux. Bien, al menos ahora hay una sección exclusiva para los que usamos otros SO.
  • El software en general está muy mejorado, bonito, y muy usable (aunque para ser justos, tampoco estamos hablando de una aplicación compleja como un CAD). Diría que podría dejarlo como default para mi sistema.
  • Proveen paquetes binarios para instalarlo muy fácilmente: .rpm, .deb y .tar.gz.

Lo Malo:

  • Todavía está en inglés (y Francés, Alemán, Japonés… pero en Español, todavía no).
  • Usando Compiz en Ubuntu 7.10, los efectos de transición a pantalla completa funcionan pero no del todo bien, y los deshabilité. Tiene algunos defectos gráficos muy pavos y pequeños, se ve que algunas cosas siguen siendo medio ‘hack’ sobre GTK para obtener máxima compatibilidad (será?).
  • Me gustaría que se pudiera regular la cantidad de líneas que se baja al darle a la ruedita del mouse, se me hace que es poco.

Lo Feo:

  • Sigue siendo código cerrado (por qué, Adobe? Qué ganan?). Eso sí, es gratuito.
  • Por lo tanto, no viene en ninguna distribución Linux por defecto.
  • Además, para hacerlo andar en mi arquitectura AMD64 (los binarios son para 386), tuve que bajar el .tar.gz y ejecutar el script INSTALL que viene adentro (después me avivé que estaba el .deb, pero siempre para i386, con lo cual habrá que hacer un ‘dpkg -i –force-architecture acroread_xxxx.deb’).
  • Y por último, tuve el problemita de que me pedía la librería libgtkmozembed.so [2] (en forma opcional), para lo cual tuve que bajar el XulRunner de Mozilla para Linux 386 (enlace), descomprimirla en algún lado (yo elegí ‘/usr/local/xulrunner32/’) y decirle al Adobe Reader en sus preferencias que lo busque en esa ruta.

Otra Captura:


Comparando cómo renderiza el mismo documento cada uno (Poppler vs. Adobe), va desde algo mejor a mucho mejor el software de Adobe, tanto en calidad (el hinting de las fuentes es mejor), como en la aparición de algunos “artefactos” muy sutiles (por Poppler). Soy un neófito en cuando a teoría de fuentes, pero poniendo un documento a lado del otro, se nota.

Saludos!
Marcelo

[1] En una búsqueda (muy corta) no encontré algún documento que resumiera lo no implementado con respecto al último estándar por Poppler, la librería que interpreta los PDFs para Evince y Kpdf. Sin embargo, puedo afirmar que no implementa todas las características del estándar Pdf 1.7. Acá hay un resumen de la historia.
[2]: En las FAQ del Blog de Adobe está explicado qué es, para qué sirve y como se busca si no es detectado automáticamente. Aclaro de nuevo, es opcional; el programa funciona sin hacer esto, sólo sale un cartelito más o menos molesto diciendo lo que no encuentra.

Categories: codear, linux, tests, ubuntu-ar Tags:
  1. norberto
    Sábado, 10 de noviembre de 2007 a las 22:21 | #1

    Perdon, pero PDF no era un formato libre?

  2. Marcelo
    Sábado, 10 de noviembre de 2007 a las 23:26 | #2

    (Aclaración: No soy abogado, je).

    Habiendo hecha la salvedad, PDF no es libre, es abierto. Es decir que cualquiera puede implementar lectores/escritores/procesadores del formato.

    Sin embargo, el único programa que implementa todas las características del formato (en sus últimas versiones), sigue siendo el Adobe Reader.

    Pegale una leída a los links del post, quizás tengas alguna duda que con este parrafito no pude evacuar. 🙂

    Saludos!

  3. Santiago Delgado
    Martes, 18 de diciembre de 2007 a las 13:33 | #3

    En la versión que tengo yo sobre Ubuntu (creo que es el AcroRead7, el gestor de impresión falla cuando le pides imprimir con opciones especiales como “Solo páginas pares y en modo inverso”.
    Espero que hallan solucionado este problema. Aprovecho para comentar que si fuera de código abierto ya estaría solucionado por la comunidad.
    Un saludo

  4. Marcelo
    Martes, 18 de diciembre de 2007 a las 13:41 | #4

    Mejor aún, hasta podrías corregirlo vos mismo o pagarle a alguien para que lo arregle y compartirlo con los demás. 🙂

    Marcelo

  1. Sin trackbacks aún.